El dia de ayer me hablo mi antiguo jefe, para solicitar mi apoyo, yo como siempre encantado de poder hacer lo que mas me gusca, configurar y escribir comandos, el punto era que script que se requeria era el siguiente 5 lineas de internet y 5 redes de un punto A a un punto B.

MikroTik, es una compañía letona proveedora de tecnología disruptiva de hardware y software para la creación de redes. Utiliza un sistema operativo llamado RouterOS  que convierte un PC o una placa Mikrotik RouterBOARD en un router dedicado.

.

# feb/27/2020 14:35:40 by RouterOS 6.35.4
# software id = C1RU-9KEN
#
/interface ethernet
set [ find default-name=ether6 ] name=LOCAL
set [ find default-name=ether1 ] name=WAN1
set [ find default-name=ether2 ] name=WAN2
set [ find default-name=ether3 ] name=WAN3
set [ find default-name=ether4 ] name=WAN4
set [ find default-name=ether5 ] name=WAN5
set [ find default-name=ether7 ] master-port=LOCAL
set [ find default-name=ether8 ] master-port=LOCAL
set [ find default-name=ether9 ] master-port=LOCAL
set [ find default-name=ether10 ] master-port=LOCAL
/ip pool
add name=POOLR1 ranges=1.1.1.1-1.1.1.254
add name=POOLR2 ranges=2.2.2.1-2.2.2.254
add name=POOLR3 ranges=3.3.3.1-3.3.3.254
add name=POOLR4 ranges=2.2.2.254-4.4.4.1
add name=POOLR5 ranges=3.3.3.254-5.5.5.1
/ppp profile
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.10 name=3MEGASL1 \
    rate-limit=1M/3M remote-address=POOLR1
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.20 name=3MEGASL2 \
    rate-limit=1M/3M remote-address=POOLR2
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.30 name=3MEGASL3 \
    rate-limit=1M/3M remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.40 name=3MEGASL4 \
    rate-limit=1M/3M remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.50 name=3MEGASL5 \
    rate-limit=1M/3M remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.30 name=COMPLETO \
    remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.30 name=4MEGASL3 \
    rate-limit=1M/4M remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.40 name=5MEGASL4 \
    rate-limit=1M/5M remote-address=POOLR3
add dns-server=8.8.8.8,8.8.4.4 local-address=192.10.200.30 name="12 M" \
    rate-limit=6M/12M remote-address=POOLR3
/interface pppoe-server server
add disabled=no interface=LOCAL service-name=service1
/ip address
add address=192.10.200.1/24 interface=LOCAL network=192.10.200.0
/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=WAN1
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=WAN2
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=WAN3
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=WAN4
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
    interface=WAN5
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=LINEA1 src-address=\
    1.1.1.0/24
add action=mark-routing chain=prerouting new-routing-mark=LINEA2 src-address=\
    2.2.2.0/24
add action=mark-routing chain=prerouting new-routing-mark=LINEA3 src-address=\
    3.3.3.0/24
add action=mark-routing chain=prerouting new-routing-mark=LINEA4 src-address=\
    4.4.4.0/24
add action=mark-routing chain=prerouting new-routing-mark=LINEA5 src-address=\
    5.5.5.0/24
/ip firewall nat
add action=masquerade chain=srcnat out-interface=WAN1 src-address=1.1.1.0/24
add action=masquerade chain=srcnat out-interface=WAN2 src-address=2.2.2.0/24
add action=masquerade chain=srcnat out-interface=WAN3 src-address=3.3.3.0/24
add action=masquerade chain=srcnat out-interface=WAN4 src-address=4.4.4.0/24
add action=masquerade chain=srcnat out-interface=WAN5 src-address=5.5.5.0/24
/ip route
add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark=LINEA1
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=LINEA2
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=LINEA3
add check-gateway=ping distance=1 gateway=192.168.3.1 routing-mark=LINEA4
add distance=1 gateway=192.168.4.1 routing-mark=LINEA5
/lcd
set time-interval=daily
/ppp secret
add name=A password=A profile=3MEGASL3 service=pppoe
add name=B password=B profile=3MEGASL2 service=pppoe
add name=C password=C profile=3MEGASL3 service=pppoe
add name=D password=D profile=3MEGASL4 service=pppoe
add name=E password=E profile=3MEGASL5 service=pppoe
add name=ALBERTO password=ALBERTO profile=4MEGASL3 service=pppoe
add name=ARTEMIO password=ARTEMIO profile=4MEGASL3 service=pppoe
add name=ARTURO password=ARTURO profile=4MEGASL3 service=pppoe
add name=CAROLINA password=CAROLINA profile=5MEGASL4 service=pppoe
add name=CIBER password=CIBER profile=COMPLETO service=pppoe
add name=COACANGEL password=COACANGEL profile=4MEGASL3 service=pppoe
add name=COACCANDIDO password=COACCANDIDO profile=4MEGASL3 service=pppoe
add name=COACCARLOS password=COACCARLOS profile=4MEGASL3 service=pppoe
add name=COACDANITORRES password=COACDANITORRES profile=3MEGASL5 service=\
    pppoe
add name=COACDIANA password=COACDIANA profile=3MEGASL3 service=pppoe
add name=COACESCFC password=COACESCFC profile=5MEGASL4 service=pppoe
add name=COACGERMAIN password=COACGERMAIN profile=4MEGASL3 service=pppoe
add name=COACMARIAELENA password=COACMARIAELENA profile=5MEGASL4 service=\
    pppoe
add name=COACMAYRA password=COACMAYRA profile=3MEGASL5 service=pppoe
add name=COACMIGUEL password=COACMIGUEL profile=4MEGASL3 service=pppoe
add name=COACOFELIA password=COACOFELIA profile=4MEGASL3 service=pppoe
add name=COACREBECA password=COACREBECA profile=4MEGASL3 service=pppoe
add name=COACROSYH password=COACROSYH profile=4MEGASL3 service=pppoe
add name=COACSATURNINO password=COACSATURNINO profile=4MEGASL3 service=pppoe
add name=COACVICTOR password=COACVICTOR profile=4MEGASL3 service=pppoe
add name=DELFINO password=DELFINO profile=4MEGASL3 service=pppoe
add name=EBER password=EBER profile=5MEGASL4 service=pppoe
add name=JONATHAN password=JONATHAN profile=4MEGASL3 service=pppoe
add name=MODELORAMA password=MODELORAMA profile=4MEGASL3 service=pppoe
add name=PABLO1 password=PABLO1 profile=3MEGASL3 service=pppoe
add name=PUNTO1 password=PUNTO1 profile=3MEGASL3 service=pppoe
add name=SANTIAGO password=SANTIAGO profile=4MEGASL3 service=pppoe
add name=SOTELO password=SOTELO profile=4MEGASL3 service=pppoe
add name=TEST password=TEST profile=4MEGASL3 service=pppoe
add name=TIMO password=TIMO profile=5MEGASL4 service=pppoe
add name=ROBERTO password=ROBERTO profile=3MEGASL3 service=pppoe
add name=PLACIDO password=PLACIDO profile=3MEGASL3 service=pppoe
add name=RAUL password=RAUL profile=4MEGASL3 service=pppoe
add name=ABRAHAM password=ABRAHAM profile=3MEGASL3 service=pppoe
add name=AGUSTIN password=AGUSTIN profile=4MEGASL3 service=pppoe
add name=PABLO password=PABLO profile=4MEGASL3 service=pppoe
add name=APOLONIO password=APOLONIO profile=5MEGASL4 service=pppoe
add name=SANTOSM password=SANTOSM profile=5MEGASL4 service=pppoe
add name=SANTOS password=SANTOS profile=4MEGASL3 service=pppoe
add name=BENJAMIN password=BENJAMIN profile=4MEGASL3 service=pppoe
/system clock
set time-zone-name=America/Mexico_City
/system routerboard settings
set protected-routerboot=disabled